How to deal with the Lower PHP version syntax error?

Our free Magento Mobile App Extension does not support the lower versions of PHP. It supports PHP version 5.5 and above. If you have a lower PHP version, then your app may face issues due to the API syntax errors.

In order to overcome this situation, you can manually change the code. To do so, follow the given steps.

Steps:-
1. root folder/app/code/local/Mss/Connector/controllers/Customercontroller.php
2. Search for this text on file ( public function getcountriesAction() )
3. Replace this code with the code given below:-

if($states->getData()):
$countriesArray[]=array(‘value’=>$country[‘value’],’name’=>$country[‘label’],’state’=>$states->getData());
else:
$countriesArray[]=array(‘value’=>$country[‘value’],’name’=>$country[‘label’],’state’=>array());
Endif;

Leave a Reply